source: branches/AlphaChannel/Install/deb/debian/rules

Last change on this file was 160, checked in by chronos, 6 years ago
  • Added: StdAI from original game. Previously used only AI dev kit.
  • Property svn:executable set to *
File size: 989 bytes
Line 
1#!/usr/bin/make -f
2
3# Set temporary HOME for lazarus primary config directory
4export HOME=$(CURDIR)/tmphome
5
6ROOT = $(CURDIR)/debian/c-evo
7
8override_dh_auto_clean:
9 $(RM) -r lib
10 $(RM) lib c-evo
11
12override_dh_auto_build:
13 cd AI/StdAI && lazbuild --build-mode=Release StdAI.lpi
14 mv AI/StdAI/libstdai.so AI/StdAI/libstdai-$(DEB_HOST_ARCH).so
15 lazbuild --build-mode=Release Integrated.lpi
16
17override_dh_auto_install:
18 install -d -m 755 $(ROOT)/usr/share/c-evo
19 install -s -m 755 c-evo $(ROOT)/usr/share/c-evo
20 install -d -m 755 $(ROOT)/usr/bin
21 install -m 755 debian/c-evo.sh $(ROOT)/usr/bin/c-evo
22 install -d -m 755 $(ROOT)/usr/share/applications
23 install -m 755 Install/deb/c-evo.desktop $(ROOT)/usr/share/applications
24 install -d -m 755 $(ROOT)/usr/share/pixmaps
25 install -m 644 Graphics/c-evo_64x64.png $(ROOT)/usr/share/pixmaps/c-evo.png
26 install -d -m 755 $(ROOT)/usr/share/c-evo/AI/StdAI
27 install -m 644 AI/StdAI/libstdai-$(DEB_HOST_ARCH).so $(ROOT)/usr/share/c-evo/AI/StdAI
28
29%:
30 dh $@
Note: See TracBrowser for help on using the repository browser.