source: trunk/Install/deb/debian/rules

Last change on this file was 225, checked in by chronos, 3 days ago
  • Fixed: Detect relative Linux share application path.
  • Fixed: Package install scripts.
  • Property svn:executable set to *
File size: 981 bytes
Line 
1#!/usr/bin/make -f
2
3# Set temporary HOME for lazarus primary config directory
4export HOME=$(CURDIR)/tmphome
5
6ROOT = $(CURDIR)/debian/acronym-decoder
7
8override_dh_auto_clean:
9 $(RM) -r lib
10 $(RM) lib *.res AcronymDecoder
11
12override_dh_auto_build:
13 lazbuild --build-mode=Release AcronymDecoder.lpi
14
15override_dh_auto_install:
16 install -Dm755 AcronymDecoder -t $(ROOT)/usr/bin
17 install -Dm644 Languages/*.po -t $(ROOT)/usr/share/AcronymDecoder/Languages
18 install -Dm644 Packages/Common/Languages/*.po -t $(ROOT)/usr/share/AcronymDecoder/Languages
19 install -Dm644 Install/shared/acronym-decoder.xml -t $(ROOT)/usr/share/mime/packages
20 install -Dm644 Install/shared/AcronymDecoder.desktop -t $(ROOT)/usr/share/applications
21 install -Dm644 Images/AcronymDecoder.png -t $(ROOT)/usr/share/icons/hicolor/256x256/apps
22 install -Dm644 Images/AcronymDecoder.png $(ROOT)/usr/share/pixmaps/application-adp.png
23 install -Dm644 Examples/*.adp -t $(ROOT)/usr/share/AcronymDecoder/Examples
24
25%:
26 dh $@
Note: See TracBrowser for help on using the repository browser.