source: trunk/Install/deb/debian/rules

Last change on this file was 389, checked in by chronos, 2 weeks ago
  • Modified: Added vector logo and generated raster logo with resolution 256x256.
  • Property svn:executable set to *
File size: 1.1 KB
Line 
1#!/usr/bin/make -f
2
3# Set temporary HOME for lazarus primary config directory
4export HOME=$(CURDIR)/tmphome
5
6ROOT = $(CURDIR)/debian/xtactics
7
8override_dh_auto_clean:
9 $(RM) -r lib
10 $(RM) lib *.res xtactics
11
12override_dh_auto_build:
13 lazbuild --build-mode=Release xtactics.lpi
14
15override_dh_auto_install:
16 install -Dm755 xtactics -t $(ROOT)/usr/bin
17 install -Dm644 Languages/*.po -t $(ROOT)/usr/share/xtactics/Languages
18 install -Dm644 Packages/Common/Languages/*.po -t $(ROOT)/usr/share/xtactics/Languages
19 install -Dm644 Packages/CoolStreaming/Languages/*.po -t $(ROOT)/usr/share/xtactics/Languages
20 install -Dm644 Images/Maps/*.png -t $(ROOT)/usr/share/xtactics/Images/Maps
21 install -Dm644 Systems/*.xts -t $(ROOT)/usr/share/xtactics/Systems
22 install -Dm644 Install/deb/xtactics.desktop -t $(ROOT)/usr/share/applications
23 install -Dm644 Install/deb/xtactics.xml -t $(ROOT)/usr/share/mime/packages
24 install -Dm644 Images/256x256/xtactics.png -t $(ROOT)/usr/share/pixmaps
25 install -Dm644 Images/256x256/xtactics.png $(ROOT)/usr/share/pixmaps/application-xtg.png
26 install -Dm644 Images/256x256/xtactics.png $(ROOT)/usr/share/pixmaps/application-xts.png
27
28%:
29 dh $@
Note: See TracBrowser for help on using the repository browser.