source: trunk/Install/deb/debian/rules

Last change on this file was 153, checked in by chronos, 8 days ago
  • Fixed: Detection of languages directory on Linux.
  • Fixed: Top left menu alignment.
  • Modified: Improved debian control script.
  • Property svn:executable set to *
File size: 682 bytes
Line 
1#!/usr/bin/make -f
2
3# Set temporary HOME for lazarus primary config directory
4export HOME=$(CURDIR)/tmphome
5
6ROOT = $(CURDIR)/debian/translines
7
8override_dh_auto_clean:
9 $(RM) -r lib
10 $(RM) lib *.res TransLines
11
12override_dh_auto_build:
13 lazbuild --build-mode=Release TransLines.lpi
14
15override_dh_auto_install:
16 install -Dm755 TransLines -t $(ROOT)/usr/bin
17 install -Dm644 Install/deb/TransLines.desktop -t $(ROOT)/usr/share/applications
18 install -Dm644 Images/64x64/TransLines.png -t $(ROOT)/usr/share/pixmaps
19 install -Dm644 Languages/*.po -t $(ROOT)/usr/share/TransLines/Languages
20 install -Dm644 Packages/Common/Languages/*.po -t $(ROOT)/usr/share/TransLines/Languages
21
22%:
23 dh $@
Note: See TracBrowser for help on using the repository browser.