Last change
on this file was 2, checked in by chronos, 5 years ago |
|
-
Property svn:executable
set to
*
|
File size:
774 bytes
|
Line | |
---|
1 | #!/usr/bin/make -f
|
---|
2 |
|
---|
3 | # Set temporary HOME for lazarus primary config directory
|
---|
4 | export HOME=$(CURDIR)/tmphome
|
---|
5 |
|
---|
6 | ROOT = $(CURDIR)/debian/graphic-test
|
---|
7 |
|
---|
8 | override_dh_auto_clean:
|
---|
9 | $(RM) -r lib
|
---|
10 | $(RM) lib c-evo
|
---|
11 |
|
---|
12 | override_dh_auto_build:
|
---|
13 | lazbuild --build-mode=Release GraphicTest.lpi
|
---|
14 |
|
---|
15 | override_dh_auto_install:
|
---|
16 | install -d -m 755 $(ROOT)/usr/share/GraphicTest
|
---|
17 | install -s -m 755 GraphicTest $(ROOT)/usr/share/GraphicTest
|
---|
18 | install -d -m 755 $(ROOT)/usr/bin
|
---|
19 | install -m 755 GraphicTest $(ROOT)/usr/bin/GraphicTest
|
---|
20 | install -d -m 755 $(ROOT)/usr/share/applications
|
---|
21 | install -m 755 Install/deb/GraphicTest.desktop $(ROOT)/usr/share/applications
|
---|
22 | install -d -m 755 $(ROOT)/usr/share/pixmaps
|
---|
23 | install -m 644 Install/deb/GraphicTest.png $(ROOT)/usr/share/pixmaps/GraphicTest.png
|
---|
24 |
|
---|
25 | %:
|
---|
26 | dh $@
|
---|
Note:
See
TracBrowser
for help on using the repository browser.